KeePassXC Auto-Type-Einstellungen nicht auffindbar

Debian 12 (Bookworm), voll gepatcht mit Gnome-Desktop
KeePassXC 2.7.4 (das Aktuelle aus dem Debian-Repository)

Mein Versuch, Auto-Type einzuschalten, scheitert daran, dass ich in KeePassXC bei Tools → Settings → General neben „Basic“ keinen Reiter „Auto-Type“ sehe. Muss ich das woanders einstellen, oder funktioniert Auto-Type in dieser Version nicht? (Ich habe gelesen, dass es Schwierigkeiten unter Wayland gibt. Für KeePass2 gibt es wohl einen Workaround , aber der gefällt mir nicht, so dass ich extra für Auto-Type auf KeePassXC wechsle.)

Ich kann dir leider nicht beantworten, warum bei Dir Auto-Type nicht zur Verfügungsteht. An deiner Stelle würde ich mir mal das KeePassXC 2.7.6 Appimage installieren und schauen wie es damit aussieht. Ich habe bei mir (EndeavourOS und KeePassXC 2.7.6) gerade testweise eine Wayland-Session gestartet und Auto-Type scheint uneingeschränkt zu funktionieren.

Auch bei mir unter Ubuntu 20.04.6 LTS und Wayland mit KeePassXC 2.7.6 als deb aus dem Ubuntu keepassxc ppa kein Problem.

Aber vielleicht hat ja dies etwas mit deinem Problem zu tun:
https://gitlab.tails.boum.org/tails/tails/-/issues/19339
und/oder
https://gitlab.tails.boum.org/tails/tails/-/issues/19582

Danke für die Antworten! Ich habe nun testweise das Appimage installiert (Debian Sid ist auch noch bei 2.7.4). Siehe da: Die Auto-Type-Einstellungen tauchen wieder auf und Auto-Type funktioniert! Wahrscheinlich liegt es an an dem von @ToKu verlinkten Problem.

Jetzt bin ich am Zweifeln. Das Browser-Addon (das wohl auch mit 2.7.4 funktionieren würde) möchte ich wegen der geringeneren Sicherheit gegenüber Auto-Type nicht nehmen und eigentlich installiere ich ungern AppImages, insbesonderen, wenn es die App auch im Repository gibt. Aber wahrscheinlich werde ich mich für letzteres entscheiden…

Installiere normal aus den Repository und starte KeepassXC mit dem Parameter

-platform xcb

Dann funktioniert auch Auto-Type
Grüße

@sonne Du bist großartig, vielen Dank!
Hab’s jetzt nach dem Userguide noch etwas anders gelöst und in ~/.profile den Befehl „export QT_QPA_PLATFORM=xcb“ eingetragen - Relogin und fertig.

Leider verstehe ich nicht wirklich, was das macht, da es sich um die Kommunikation zwischen Wayland und X.Org-Server tief im Grafiksubsystem von Linux handelt. Hoffentlich habe ich mir damit nicht ein höheres Sicherheitsrisiko eingefangen, als mit dem im Eröffnungspost verlinkten Workaround für Keepass2. Nach ersten Recherchen sollte dem aber nicht so sein :thinking:

Ich hoffe und denke das es so i.O. ist. Sonnst hätten sehr viele User ein Problem.
Ich starte es per bash script das wiederum per Autostart nach dem booten ausgeführt wird.