Pihole massig PTR Anfragen obwohl Netguard auf Smartphone läuft?

Hallo Zusammen,
ich denke ich habe da ein großes Verständnisproblem oder evtl. läuft da doch was falsch?
Also ich habe Netguard auf dem Smartphone und dort zwei DNS Server eingetragen in den „Erweiterten Einstellungen“ unter „VPN-DNS“ sowie es von Kuketz im Blog beschrieben wird. Außerdem verwende ich GrapheneOS und im in meinem LAN habe ich ein Pi-hole laufen.

Es ist Jetzt so das es einmal am Tag, immer wenn ich morgens das Smartphone zum ersten mal entweder einschalte oder entsperre, tausende PTR Anfragen im Pihole zu sehen sind. Darüber hinaus gibt es immer wieder mal einzelne „A“ Einträge zu Adressen die sich auch in meinem WLAN befinden über den Tag verteilt…

Was ich jetzt nicht verstehe… durch Netguard auf dem Smartphone und den dort hinterlegten DNS Servern, sollte doch eigentlich von diesem Smartphone überhaupt nichts im Pihole auftauchen oder lieg ich da falsch? Wir haben noch weitere Smartphones in dem WLAN aber diieses Smartphone mit GrapheneOS/Netguard ist aktuell mit Abstand der Spitzenreiter im Pihole.

Ist das erklärbar?
Viele Grüße
mabox

Ist das VPN auch wirklich aktiv? Ansonsten könnte es das erklären, dass dein Smartphone per DHCP deinen Pi-hole als DNS-Server bekommt und fleissig dort nachfragt. Bzw. beim Einschalten dauert es wohl auch „einen Moment“ bis das VPN auf dem Smartphone aktiv und hochgefahren ist. Das würde „ein paar“ Anfragen, aber nicht „Tausende“ erklären. Oder dein Smartphone fragt in so kurzer Zeit sehr, sehr, also aussergewöhnlich viele Adressen an… :man_shrugging:
Mit meiner WireGuard Lösung passieren beim Wechsel/Aktivieren auch „komische“ Dinge, soll heissen dass dann kurzzeitig weder der Pi-hole zuhause noch der Pi-hole im WireGuard VPN genutzt wird. Aber das sind ein oder zwei Sekunden und sicher keine Tausende DNS Anfragen… :thinking:

Hallo,
danke für Deine Antwort…
Also ich konnte jetzt vorhin folgendes beobachten und es ein wenig eingrenzen.
Mein Smartphone war jetzt den ganzen Tag nicht in meinem WLAN bzw. heute Morgen nur kurz.

Es war wie folgt:

  • Heute Morgen habe ich das Smartphone eingeschaltet… dabei war die Lease Time vom DHCP Server noch aktiv → es sind keine Anfrage im Pi-hole zu sehen.
  • Den ganze Tag war ich jetzt außer Haus und bin vorhin zurückgekommen. Dabei wurde die Lease Time vom DHCP aktualisiert, die steht bei mir auf 12h und prompt meckert das Pi-hole da innerhalb von 60 Sek. über 1000 Anfragen von dem Gerät kamen… wie oben beschrieben massig PTR Anfragen und einige wenige A Records… Bei den A ist jetzt aber z.B. auch „chat.signal.org“ mit dabei… das dürfte ja auf keinen Fall sein.

Es ist also wohl so das wenn das Smartphone den DHCP Server kontaktiert diese Anfragen am Netguard vorbei gehen? Ganz komisch ist ja die Signal Adresse, die Anfrage ging auch erst ca. 30 Minuten später ans Pi-hole, da waren die PTR Anfragen schon eine ganze Weile vorbei.

Wie gesagt Netguard VPN ist ganz sicher aktiv und im Netguard sind auch zwei VPN-DNS eingestellt…

Verwirrt mich jetzt ein wenig das Ganze…

EDIT:
Was hatte es nochmal auf sich mit der folgenden VPN Einstellung innerhalb von GrapheneOS (nicht Netguard selbst):

  • Verbindungen ohne VPN blockieren
    Diese ist aktuell bei mir deaktiviert. Weiß gerade nicht mehr ob ich die früher mal aktiviert hatte und das evtl. eine Rolle spielt…