Fritzbox Pihole Gast-Wlan - Kein Internetzugriff

Habe nach Blog-Anleitung Pihole installiert. Nutze die FB 7490 Vers 7.57.
Im Wlan-Gastnetz ist jetzt kein Internetzugrifff mehr möglich.
Auf dem Client kommt die Meldung
„Auf den Privaten DNS-Server kann nicht zugegriffen werden“ oder"…Gast hat keinen Internetzugriff"
Fehler vermute ich in der Konfiguration der FB.
Welche Infos braucht ihr um mir zu helfen?

am besten alle

1 „Gefällt mir“

??alle?? Bin nur ambitionierter Anfänger.
Hab die Konfiguartion der FB nach Anleitung vorgenommen
kein DNS-Rebind-Schutz


In der Dokumentation von Pihole ist das ganze egtl sehr gut beschrieben.

@ smithy7 Danke, für den Hinweis.
Konnte mein Problem aber leider noch nicht beheben.

Dann muss ja noch irgendwo ein Fehler sein. Nach welcher Anleitung hast du denn gearbeitet?

Du kannst auch einmal ein Debug Log erstellen. Entweder über die Weboberfläche unter Tools> Generate debug log oder mit pihole -d im Terminal vom Raspberry(?) wenn du einen benutzt. Die komplette Ausgabe müsstest du dann hier Posten, bzw. mir sonst per PN schicken.

Nach dieser Anleitung
https://www.kuketz-blog.de/pi-hole-einrichtung-und-konfiguration-mit-fritzbox-adblocker-teil1/

PN kann ich wohl noch nicht versenden, wenn ich auf dein Symbol klicke kommt keine Banner „Nachricht“ oder es wird von unbekannten Mächten geblockt.

Dann solltest du dich sonst an das Pihole Forum wenden. Dort das Problem schildern und den Link vom Debug Token posten.

PN schreiben ist hier echt verzwickt.
Einfachste Möglichkeit.
Auf die Flagge klicken um einen Beitrag zu melden.
Dort kann man dann auswählen ob man den Beitrag einen Mod melden möchte oder einfach den Ersteller eine PN schicken will.
So handhabe ich es.
@_Albert @smithy7

2 „Gefällt mir“

Die dort als DNS-Server zugewiesenen Adressen sehen mir nicht nach deinem Pihole aus :thinking:
Aber auch damit sollte zumindest „der Internetzugriff“ funktionieren:

$ host 94.140.14.140
140.14.140.94.in-addr.arpa domain name pointer dns-unfiltered.adguard.com.

$ host 176.9.93.198
198.93.9.176.in-addr.arpa domain name pointer dnsforge.de.

Ein Ipad kam ohne Probleme ins GastWlan, d.h. ich muss das Problem bei den Clients weiter untersuchen. Danke für eure Mithilfe.

Android und es wird „Privates DNS“ verwendet?
Hast du in der Fritzbox für das Gastnetzwerk einen Netzwerkfilter aktiv?
Z.B. das Profil „Nur surfen und mailen“?

Das Private DNS bei Android läuft fast immer über DoT, also über Port 853.
Der wird bei der Fritzbox meines Wissens nach in diesen Profil nicht freigegeben, also müsstest du es manuell hinzufügen, bzw. ein eigenes Profil definieren.
Schlussfolgernd kann Android sich nicht zum DoT Server verbinden, und wenn du diesen explizit aktiviert hast, hast du dann, soweit Ich mich erinnere, die Meldung dass kein Zugriff auf das Internet möglich ist, da der Connectivity Check dann auch fehlschlägt.

Für ein eigenes Profil, das mailing, surfen & DNS zulässt (aber damit auch die in der Fritzbox getätigten Einstellungen umgehen lässt): Als Ziel folgende Ports & Protokolle freigeben
UDP & TCP: 443 (HTTPS, QUIC)
TCP: 80 (HTTP)
TCP: 853 (DOT)
UDP & TCP: 53 (DNS) - falls es möglich sein soll, dass Clients im Gastnetzwerk unverschlüsselt auf andere DNS Server als die (auf der) Fritzbox (konfigurierten) zugreifen können.
Und die Mail Ports:
TCP: 143 & 993 (IMAP)
TCP: 465 & 587 (SMTP)
TCP: 110 & 995 (POP3)

Also Ich würde sagen erstmal die „Kindersicherung“/Netzwerkfilter in der Fritzbox überprüfen.